/
http://forum.claroline.net/
fr_FR

Veuillez patienter...

Téléchargement

Téléchargement et planning

Téléchargement et installation

Claroline Connect 16.09

La version 16.09 de Claroline Connect est sortie ce 14 octobre 2016. Cette version bénéficie de la correction d'une centaine de bugs.

Un forum est disponible.

La documentation va être adaptée au plus vite.

Exigences avant l'installation

Assurez-vous que vous avez d'abord installé:

  • PHP >= 5.5 avec les extensions suivantes:
    • curl
    • fileinfo
    • gd
    • intl
    • mcrypt
    • ffmpeg (optionnel)
    • zip archive
    • json
  • MySQL/MariaDB >=5.0 et < 5.7

Des informations techniques plus détaillées peuvent être obtenues ici.

Installation à partir d'un fichier archive

Pour chaque version de la plateforme, les ressources (sources pré-extraites, database dump, etc.) sont disponibles à l'adresse packages.claroline.net/releases.

Le moyen le plus rapide pour démarrer est de taper les commandes suivantes dans un terminal:

  • curl packages.claroline.net/releases/latest/claroline-16.09.tar.gz | tar xzv
  • cd claroline-16.09
  • php scripts/configure.php
  • composer fast-install

Attention : les mises à jour se font obligatoirement par lignes de commande dans un terminal.

Installation depuis la source

La procédure d'installation comprend différentes étapes à exécuter dans l'ordre (extraire les fichiers php source, installer les dépendances, créer la base de données, etc.). A l'exception de l'étape de configuration, le processus est entièrement géré par des scripts composer qui sont listés dans le fichier composer.json.

Pour une nouvelle installation, les commandes sont

  • git clone http://github.com/claroline/Claroline
  • cd Claroline
  • php scripts/configure.php
  • composer sync-dev
Mise à jour

Pour mettre à jour une installation de développement, il faut simplement charger les derniers changements du répertoire et utiliser le script sync-dev:

  • git pull
  • composer sync-dev

Planning de développement

Les nouveautés présentes dans la version 16.09

Vous trouverez la liste des nouvelles fonctionnalités et des bugs corrigés ici.

Développements futurs

Avant d'introduire de nouvelles fonctionnalités, nous avons décidé de mettre la priorité sur la stabilisation de la plateforme. Ceci permettra d'homogénéiser les différentes parties du code et de gagner en performance.

Pour installer la version de développement

Vous aurez besoin d'au moins:
  • PHP >= 5.5 avec les extensions suivantes:
    • curl
    • fileinfo
    • gd
    • intl
    • mcrypt
    • ffmpeg (optionnel)
    • zip archive
    • json
  • MySQL/MariaDB >=5.0 et < 5.7
  • Une version récente de composer
  • node.js >= 5.5
  • npm >= 3.7
  • git

Il est vivement recommandé d'utiliser un environnement de type UNIX.

La version 1.x de Claroline n'est plus maintenue

Tous nos efforts sont tournés vers le développement de Claroline Connect. Nous n'investissons dès lors plus dans le développement de l’ancienne version de Claroline. La plateforme de support aux utilisateurs campus.claroline.net, ainsi que la messagerie [email protected] ont par conséquent été supprimées.

Dernières mises à jour:

Correctif de la mise à jour Claroline 1.11.10 (2014-02-28)

Un correctif d’erreur pour le téléchargement de la version Claroline 1.11.10 corrige un problème dans l’outil de parcours pédagogique.

L’ARCHIVE COMPLÈTE est disponible via :

Pour tous ceux qui téléchargent la version 1.11.10, le correctif est déjà inclus dans la plateforme.

Mise à jour Claroline 1.12 (alpha2) est disponible en test (2014-02-18)

Les informations concernant ces mises à jour se trouvent sur les forums.

La mise à jour de la version alpha de Claroline 1.12 est disponible en version de test.

ATTENTION : Cette release est une version test et n’est pas encore adaptée à la production !

zip archive (Windows and Mac OS X)

tar.gz archive (UNIX, Linux)

Autres versions à télécharger : Sourceforge

Modules complémentaires: Claroline Packages