Veuillez patienter...
/
https://forum.claroline.net/
/
/themes/claroline/bootstrap.css?v=373695b0789add75084adaa2e947337f
fr_FR
Vous utilisez un navigateur non pris en charge. Pour éviter tout fonctionnement indésirable, veuillez utiliser une version récente d'un navigateur majeur. (http://browsehappy.com). Internet Explorer est supporté à partir de la version 11.

[Sujet] Problème de désactivation de l'espace personnel...

Messages par page
Auteur Messages

17/11/2017 15:39

Bonjour à tous,

Je viens d'installer Claroline (10.6.4) sur une VM (type KVM) Debian 9.2 (1 socket - 2 cores / 8Go RAM).

J'ai créé un utilisateur "test". J'ai ensuite créé un rôle nommé "Élèves" où j'ai décoché la case "Espace personnel". J'ai attribué l'utilisateur "test" à ce rôle.

Lorsque je me suis loggé sur le profil de cet utilisateur "test", celui-ci avait toujours son espace personnel actif !

 

J'ai donc supprimé l'utilisateur "test". Je l'ai recréé en lui attribuant le rôle "Élèves" et là...en me loggant c'était OK.

 

Est-ce que quelqu'un à déjà constaté ce bug ?

Il semblerait que les droits sur le profil de l'utilisateur ne se mettent pas tous à jour lorsqu'un rôle est attribué APRES la création de l'utilisateur.

 

Merci.

Il y a 1 an


18/11/2017 09:31

Il ne s'agit pas d'un bug mais bien du comportement voulu.

La case "Espace personnel", porte sur la création ou non d'un espace personnel quand on crée un utilisateur avec ce role.

Si l'espace à déjà été créé, il faut le supprimer depuis la liste des espaces ...

Il y a 1 an


20/11/2017 12:04

Bonjour,

Merci pour l'info. Je ne pensais pas que l'on pouvait supprimer l'espace personnel d'un utilisateur une fois celui-ci créé.

Bonne journée

Il y a 1 an